[Mono-devel-list] Function name conflict
joe at otee.dk
Fri Nov 19 08:17:25 EST 2004
I am embedding mono in a macosx application that also uses cocoa and carbon.
The following functions are also defined by the system framework.
I have changed the names to resolve the name conflict in my mono build.
(Some apple tools like libmallocdebug don't like if you have duplicate names
in an application and i get linker warnings which i wanted to avoid)
I would happily provide a patch for it if it will actually be checked into
cvs? Would you just want a mono_ prefix in front of those functions? Or what
are the naming rules?
More information about the Mono-devel-list