[Mono-dev] error compiling mod_mono 1.2.5 with apache 1.3

César González cesar at eureka-sistemas.com
Wed Sep 26 05:33:33 EDT 2007

Hi Marek,

Marek Habersack escribió:
> What is the version of apr 1.3 uses? 0.9.x?
On debian, apache-dev (version 1.3.34) depends on apache2-common, wich 
depends on libapr1-dev (1.2.7).

Anyway, I have tested mod_mono 1.2.5 with apr 0.9 and change mod_mono.h 
to not to include unixd.h (apache 2 file). The error with these changes 
is the following :

mod_mono.c:99: error: expected specifier-qualifier-list before 'apr_shm_t'
mod_mono.c:121: error: expected specifier-qualifier-list before 
mod_mono.c:128: error: 'APR_LOCK_FCNTL' undeclared here (not in a function)

Seems that mod_mono is not compatible with the old api 0.9.



More information about the Mono-devel-list mailing list