[Mono-dev] XSP + mono 1.2.6 (and SVN)

Stephen Kou skou at cs.ucla.edu
Wed Feb 27 23:15:15 EST 2008

Hi everyone,

I've been trying to get xsp to work on the SVN build of both mono and 
xsp itself.  I manage to get everything built ok, but after i start up 
xsp and a request is received, the program seems to hang (the socket 
remains open -- my browser continues to wait for a response, no output 
on screen in xsp). 

After investigating further and putting debug messages all over the 
class library and XSP, I find that the call to 
AppDomain.CreateInstanceAndUnwrap is never returning in the last line of 
System.Web.Hosting.ApplicationHost.CreateApplicationHost.  I haven't 
gone into AppDomain.cs yet to go through line by line; i was hoping 
someone could tell me if i was doing anything wrong first before having 
to dive into the corlib code, since i feel that should be stable by now. 

I tried on ubuntu 7.10, as well as a redhat machine i have.  Both have 
the same results.  I tried mono1.2.6 and xsp1.2.6 also, both with the 
same results.  The apt-get install version of mono and xsp work fine, 
but the version is rather old (bereft of the .net 3.5 classes, which I 
would like to experiment with).

Does anyone have any help? 

Thank you,

More information about the Mono-devel-list mailing list