[Mono-dev] mkbundle generated windows executable troubleshooting

Vyperin vyperin at yahoo.com
Thu Jan 29 12:04:22 EST 2009

bpack958 wrote:
> I've solved this issue, although i'm not quite clear why the test apps
> still worked.

Can you be more specific about how you resolved the issue, because since
I've installed Mono > 2.0.1 on Windows (eg. 2.2, 2.4 preview 1) I have been
encountering the same issue: mkbundle -o <App.exe> --deps -z
<NETLibrary.dll> <NETApp.exe> compiles an executable who runs and exits
imediately, or runs and spawns a process that hangs indefinitely.

bpack958 wrote:
> I did not have the machine config file in the right directory
> (../etc/mono/ ...) which stopped the app from working.

Provided your post I have been trying to pass: --machine-config
The result is the same + a warning about specific machine.config of my

For more details - the system is a Vista Business x64 and I call mkbundle
from a Cygwin shell.
All worked ok on Mono 2.0.1 which I had previously installed.

View this message in context: http://www.nabble.com/mkbundle-generated-windows-executable-troubleshooting-tp19025329p21731096.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list