[Mono-dev] Compiling Mono v2.4 RC2 (Solaris 10 SPARCv9)

John M john_mandia at yahoo.com
Tue Jun 16 06:24:21 EDT 2009

Has anyone come across this problem?:

I am trying to compile mono on Solaris 10.
I got pkgconfig, glib compiled and ran configure successfully but it just
fails while running gmake for mono 2.4

bash-3.00# gmake
gmake  all-recursive
gmake[1]: Entering directory `/mono_downloads/mono-2.4'
Making all in po
gmake[2]: Entering directory `/mono_downloads/mono-2.4/po'
Making all in mcs
gmake[3]: Entering directory `/mono_downloads/mono-2.4/po/mcs'
test ! -f ./mcs.pot || \
  test -z "es.gmo ja.gmo de.gmo" || gmake es.gmo ja.gmo de.gmo
gmake[4]: Entering directory `/mono_downloads/mono-2.4/po/mcs'
: --update es.po mcs.pot
: --update ja.po mcs.pot
: --update de.po mcs.pot
rm -f de.gmo && : -c --statistics -o de.gmo de.po
mv: cannot access t-de.gmo
gmake[4]: *** [de.gmo] Error 2
gmake[4]: Leaving directory `/mono_downloads/mono-2.4/po/mcs'
gmake[3]: *** [stamp-po] Error 2
gmake[3]: Leaving directory `/mono_downloads/mono-2.4/po/mcs'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/mono_downloads/mono-2.4/po'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/mono_downloads/mono-2.4'
gmake: *** [all] Error 2
bash-3.00# pwd
bash-3.00# pwd



Thracx wrote:
> <P>In short, it's not working for me but I'm willing to keep trying and
> document my experiences if I can get some help from the Mono developer
> community.  I apologize for the lengthy post but I figured that I might as
> well be thorough.</P>
> Background:<BR>
> <P>
> I have been wrestling with trying to compile various versions of Mono. 
> After a good deal of trouble, I managed to build v2.0.1 on my Solaris 10
> SPARCv9 machine.  It has issues (i.e. bugs in Mono), but I think the build
> itself was successful.
> </P><P>
> I believe many of my issues have been fixed in later Mono fixes, but thus
> far I have been unable to build Mono v2.2, v126637, and v2.4 RC2.  I'm
> hoping to be able to utilize v2.4 when it's released but if I can't
> compile the RC2,  obviously I'll have an issue when v2.4 becomes official. 
> If it's a bug with me, I could certainly use some help.  If it's a bug in
> Mono, I need some help finding it so hopefully it can be fixed before v2.4
> is released later this month.
> </P><P>
> I hope to document all the issues and fixes that I've encountered thus far
> - the documentation for building Mono on Solaris is very scattered, but
> I'd hate to conclude mine with "but in the end it doesn't work".
> </P>
> Problem:<BR>
> <P>
> 'Configure' succeeds and 'make' gets all the way to where it compiles
> System.dll (with warning 'System.dll build without parts that don't depend
> on: System.Xml.dll'.  I then get "MCS   [basic] System.dll", and then the
> annoying "GC Warning: Large stack limit(...):  only scanning 8 MB"
> warning.  It's followed by a 'Compilation succeeded - 13 warnings(s)'
> message which tells me that it finished System.dll.  It then tries working
> on System.Xml.dll after doing what looks like some lexer tree reductions
> (messages like 3 rules never reduced, 1 shift-reduce conflict, etc) and
> then the "MCS    [basic] System.Xml.dll" message.  This is the last thing
> I see.  I can wait for over 16 hours and nothing happens, other than
> prstat reporting that 'mono' has used 16+ hours of CPU time.  It gives an
> '.../class/lib/basic/System.Xml.dll]  Error 130' message after I kill it
> but that is just from me interrupting it.  For some reason, the build
> process is either unable to compile System.Xml.dll, or it runs something
> that hangs.  I don't see any 'compilation succeeded' message like with
> System.dll so I assume it's the former.  But it was able to compile
> System.dll so why can't it compile System.Xml.dll?
> </P>
> <P>
> As what may be an important side-note, my previous brick wall was with
> build/deps/basic-profile-check.exe.  I was able to get past this issue but
> I think it's probably the same problem as above, or at least related, so I
> thought it best to mention it:  'Configure' succeeds and 'make' gets all
> the way to where it enters the mcs directory.  I get the "The compiler
> 'mcs' doesn't appear to be usable.  Trying the 'monolite' directory."
> message and then it seems to re-try compiling and/or running
> basic-profile-check.exe and I've waiting over 16 hours and nothing else
> happens - it's hung.  When I kill it, it says
> "[build/deps/basic-profile-check.exe]  Error 127", and then gives an Error
> 130 but that's just from my interrupting it.  For some reason, the build
> process is either unable to compile basic-profile-check.exe or when it
> runs it, it hangs.  My guess is the former.  Either way, if I add my Mono
> v2.0.1 bin directory to my path, it's able to get past this problem - but
> then hangs on System.Xml.dll per above.
> </P>
> What Didn't Work:<BR>
> <P>
> First, note that my system does not have access to the Internet.  Things
> like 'make get-mono-latest' don't work for me.  Regardless, I now have a
> rather complete GNU bin directory that I've compiled myself, including GCC
> v3.4.3, TAR v1.21, ar, as, grep, ranlib, strip, ld, etc.  I've renamed the
> 'mcs' file native to Solaris to something else.  I've replaced the "-mt"
> option in gthread-2.0.pc with -D_REENTRANT.  I'm including a copy of
> libgdiplus v2.4 that I built, although I understand that's just needed for
> System.Drawing to work.
> </P><P>
> I've tried including and not including my v2.0.1 bin and lib in my
> environment to no avail.  I've tried various combinations of configure
> options such as these:  --disable-dtrace --with-gc=none
> --with-sigaltstack=no --with-ikvm-native=no --disable-mcs-build.  The
> summary at the end of Configure confirms that these work (i.e. I was
> previously using signaltstack=no...), and "TLS: pthread", which I believe
> was auto-detected correctly.  I'm using "ulimit -Hs 10240" now but it
> doesn't seem to be doing anything.  I've tried using monolite from
> mono-project.org and adding that to my path.  I've even tried letting the
> _tmpinst directory get created and then editing the scripts in it to point
> to my Mono v2.0.1 files instead of the build ones.  I have read that
> others have succeeded on Solaris 10 SPARC, so thus far I've avoid making
> any code changes to the source, but as of this post that's my next step as
> I can't think of any other avenues.
> </P><P>
> Nothing seems to let me get past this problem - any ideas?
> </P>

View this message in context: http://www.nabble.com/Compiling-Mono-v2.4-RC2-%28Solaris-10-SPARCv9%29-tp22587130p24051545.html
Sent from the Mono - Dev mailing list archive at Nabble.com.

More information about the Mono-devel-list mailing list