[Mono-dev] Mono 2.4 for ARM

Jon Shemitz Jon.Shemitz at access-company.com
Tue Jun 30 19:07:04 EDT 2009

I tried 




but not




however, on Ubuntu 8.04, both give me


make: invalid option -- D



From: Koushik K. Dutta [mailto:koush at koushikdutta.com] 
Sent: Tuesday, June 30, 2009 3:54 PM
To: Jon Shemitz; Zoltan Varga
Cc: mono-devel-list at lists.ximian.com
Subject: Re: [Mono-dev] Mono 2.4 for ARM




On 6/30/09 3:39 PM, "Jon Shemitz" <Jon.Shemitz at access-company.com>

Many thanks. --with-tls=pthread got me past my first hurdle.
Alas, now I get 
mini-arm.h:28:2: error: #error "At least one of ARM_FPU_NONE or
ARM_FPU_FPA or ARM_FPU_VFP must be defined."
and I can't seem to get past that. I've tried 
./configure --disable-mcs-build --with-tls=pthread ARM_FPU_NONE=1
ARM_FPU_NONE=1 make 
export ARM_FPU_NONE=1
and I keep getting the same error. What do I have to do to enable
software floating point (gnueabi)?


From: Zoltan Varga [mailto:vargaz at gmail.com] 
Sent: Monday, June 29, 2009 6:36 PM
To: Jon Shemitz
Cc: mono-devel-list at lists.ximian.com
Subject: Re: [Mono-dev] Mono 2.4 for ARM


  Try mono 2.4.2, or pass --with-tls=pthread to configure.


On Tue, Jun 30, 2009 at 1:59 AM, Jon Shemitz
<Jon.Shemitz at access-company.com> wrote:

I'm trying to build Mono 2.4 for an ARM device, following the
instructions at http://mono-project.com/Mono:ARM and using an existing
Scratchbox configuration. 

I downloaded mono-2.4.tar.bz2 and extracted it with `tar xjf`. The
host-mono part went fine, but when I tried to do the Scratchbox part, I
had no "arm-mono" directory. When I tried to 
> ./configure --disable-mcs-build
> make 
> make install DESTDIR=`pwd`/tmptree
in the mono-2.4 directory, `make` gave me a lot of warnings, and finally
a series of "undefined reference to `GC_local_malloc'" errors,
culminating in 

collect2: ld returned 1 exit status

make[3]: *** [pedump] Error 1

make[3]: Leaving directory

make[2]: *** [all-recursive] Error 1

make[2]: Leaving directory `/home/jon/src/dev/alp/cross/mono-2.4/mono'

make[1]: *** [all-recursive] Error 1

make[1]: Leaving directory `/home/jon/src/dev/alp/cross/mono-2.4'

make: *** [all] Error 2

Are there more up-to-date build instructions somewhere? Is ARM only
supported for 1.x? Or am I just too stupid to get Mono running on our

Mono-devel-list mailing list
Mono-devel-list at lists.ximian.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/mono-devel-list/attachments/20090630/25b66e11/attachment.html 

More information about the Mono-devel-list mailing list