[Mono-dev] Method not found: 'System.Data.Common.DbConnection.EnlistTransaction' in System.Data Version

Tomi bosak.tomas at gmail.com
Thu Sep 2 07:09:56 EDT 2010

I have tried to do this by myself, but I can't get it to work. The
problem is probably in DbConnection.cs class
because EnlistTransaction method (among others) have NET_2_0 symbols.
This method is overriden by mysql .net connector, but .net 4.0 profile
System.Data assembly version doesn't have this method probably
because of that symbol. I added NET_4_0 symbols to directives, but
none of my combinations worked. Any ideas or hints?

On 31 August 2010 11:28, Tomi <bosak.tomas at gmail.com> wrote:
> Hi folks,
> I'm using compiled fresh mono from git with .net 4.0 profile. When I
> try connect to mysql database with .net connector I get this:
> Unhandled Exception: System.MissingMethodException: Method not found:
> 'System.Data.Common.DbConnection.EnlistTransaction'.
>  at (wrapper remoting-invoke-with-check)
> MySql.Data.MySqlClient.MySqlConnection:Open ()
> However when I use System.Data.dll assembly version instead of
> version I can connect to database without problems. Any
> thoughts how to get this working with assembly version

More information about the Mono-devel-list mailing list