[Mono-dev] Method not found: 'System.Data.Common.DbConnection.EnlistTransaction' in System.Data Version

Tomi bosak.tomas at gmail.com
Thu Sep 2 09:28:09 EDT 2010

Application is ASP.NET MVC 2 targeted to .NET 4.0 and I develop it
using Visual Studio 2010. Web app is deployed simply by copying files
to my linux machine. It dies when I try to connect to the database
(only on mono, MS.NET works). ASP.NET MVC 2 targeted to .NET 3.5 works
without problems on mono. I use Apache with mod_mono and it's set to
mod-mono-server4. To be clear I did not try to change NET_2_0 symbol
to NET_4_0, I just add or (||) operator and add NET_4_0.

On 2 September 2010 13:30, Robert Jordan <robertj at gmx.net> wrote:
> On 02.09.2010 13:09, Tomi wrote:
>> I have tried to do this by myself, but I can't get it to work. The
>> problem is probably in DbConnection.cs class
>> (http://github.com/mono/mono/blob/master/mcs/class/System.Data/System.Data.Common/DbConnection.cs)
>> because EnlistTransaction method (among others) have NET_2_0 symbols.
>> This method is overriden by mysql .net connector, but .net 4.0 profile
>> System.Data assembly version doesn't have this method probably
>> because of that symbol. I added NET_4_0 symbols to directives, but
>> none of my combinations worked. Any ideas or hints?
> NET_4_0 implies NET_2_0, so the code is correct. My System.Data.dll
> (built from git master) *does* contain this method.
> How are you building your app?
> Robert
> _______________________________________________
> Mono-devel-list mailing list
> Mono-devel-list at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-devel-list

More information about the Mono-devel-list mailing list