[Mono-dev] Problem with mcs build

Cyd Haselton chaselton at gmail.com
Tue Sep 20 13:47:28 UTC 2016

Additionally I Googled the warning that appears before the build error:
warning CS8001: SDK path could not be resolved

The first two hits mention that the cause is usually due to a missing
System.Drawing.dll, but it is present in the build tree under
./external/binary-reference-assemblies/vX.x, where 'X.x' is  2.0, 4.0 and

Googling the Unhandled Exception error brings up hits from the Unity forums
and not much else.

On Sep 20, 2016 7:13 AM, "Cyd Haselton" <chaselton at gmail.com> wrote:

> While waiting for a response I ran 'make clean' then 'make V=1 2>&1 | tee
> mono_build_log.'
> I've posted the results here: http://pastebin.com/s3gHQQdg
> On Sep 19, 2016 6:02 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>> Should I run make clean and try again? Or is there something wrong with
>> the mcs/mcs Makefile?
>> On Sep 19, 2016 4:33 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>> Downloaded latest tarball, ran autogen.sh. It failed at the start of the
>>> mcs build because the mono-wrapper, mono and mcs scripts had #!/bin/sh
>>> instead of the correct path.  Fixed that, re-ran make and got the  error
>>> from my first email
>>> Pastebin here: http://pastebin.com/gdAcRKN6
>>> On Sep 19, 2016 2:23 PM, "Cyd Haselton" <chaselton at gmail.com> wrote:
>>>> Er…I *can't* do that because the instructions say that building from
>>>> git assumes mono is installed.
>>>> I'll download the latest tarball…
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-devel-list/attachments/20160920/11122c04/attachment-0001.html>

More information about the Mono-devel-list mailing list