[Mono-dev] Unable to Build Mono

Vishnu Kalapur vishnuk.2410 at gmail.com
Wed Jan 31 22:19:06 UTC 2018

Hi Alex,

Thank you for the reply. I downloaded the submodules and tried the whole process again. Those errors are gone but, now I get some strange compilation errors (Syntax errors)when I compile in Visual Studio 2015 Update 3. I have not modified anything in the sources. I would be thankful if I get any insights into it. I strongly believe that the source code on Github is syntax error free. I have attached a snapshot of the errors as it might help.

Sent from Mail<https://go.microsoft.com/fwlink/?LinkId=550986> for Windows 10

From: Alexander Köplinger<mailto:alkpli at microsoft.com>
Sent: Wednesday, January 31, 2018 6:21 PM
To: Vishnu Kalapur<mailto:vishnuk.2410 at gmail.com>
Cc: mono-devel-list at lists.dot.net<mailto:mono-devel-list at lists.dot.net>
Subject: Re: [Mono-dev] Unable to Build Mono

It looks like you didn't clone the submodules.

Run "git submodule update --init --recursive".

- Alex

On 31 Jan 2018, at 17:26, Vishnu Kalapur <vishnuk.2410 at gmail.com<mailto:vishnuk.2410 at gmail.com>> wrote:

Hello there,

I am currently working on security features of Mono Framework for which I Need to build the mono sources. I followed the steps mentioned on the Website http://www.mono-project.com/docs/compiling-mono/windows/<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.mono-project.com%2Fdocs%2Fcompiling-mono%2Fwindows%2F&data=02%7C01%7Calkpli%40microsoft.com%7C4fc79ad35fc84cef7d0c08d568c760fa%7Cee3303d7fb734b0c8589bcd847f1c277%7C1%7C0%7C636530127905664806&sdata=SKjEHu5Tdi00UBtWWkdTCt05%2BdJbfmXQIiicnyXzRpc%3D&reserved=0> . I was successful in Building the „mono.sln“ inmono/msvc Directory which was stated in the documentation. Unfortunately, I was not able to build the „net_4_x.sln“ in the mono directory. I want to build this solution file because I would like to perform some static Analysis (generate call graph from an algorithm) on ONLY some of the Projects in net_4_x.sln. I also tried building the „corelib-net_4_x“ Project from net_4_x.sln which was not dependent on any other Projects and is the start Project. Unfortunately, I was not succesful in that as well. I am attaching the screenshot of the error. It would be very kind if someone could  help me with this issue.

Sent from Mail<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgo.microsoft.com%2Ffwlink%2F%3FLinkId%3D550986&data=02%7C01%7Calkpli%40microsoft.com%7C4fc79ad35fc84cef7d0c08d568c760fa%7Cee3303d7fb734b0c8589bcd847f1c277%7C1%7C0%7C636530127905674814&sdata=sljvYYdjk9A2%2FCGQ1Lfluh0VHA05kNEjfpyEPc0pjFQ%3D&reserved=0> for Windows 10

Mono-devel-list mailing list
Mono-devel-list at lists.dot.net<mailto:Mono-devel-list at lists.dot.net>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.dot.net/pipermail/mono-devel-list/attachments/20180131/25e090cd/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: visualStudio.JPG
Type: image/jpeg
Size: 114799 bytes
Desc: visualStudio.JPG
URL: <http://lists.dot.net/pipermail/mono-devel-list/attachments/20180131/25e090cd/attachment-0001.jpe>

More information about the Mono-devel-list mailing list