[Mono-list] encoding still broken in xsp

Artur Brodowski bzdurqa@wp.pl
Mon, 08 Dec 2003 12:56:00 +0100


--=-j+PUN7zYW5EJwhwmO1g1
Content-Type: text/plain; charset=iso-8859-13
Content-Transfer-Encoding: 8bit

Hello,
I'm trying to run simple web forum using ASP.NET, but it won't display
national chars properly. See attached file:
# file login.aspx
login.aspx: UTF-8 Unicode text
Seems ok, but "Has¨o" string ("password") is diplayed as "Has┼o" in
the output. What is wrong? Is this XSP bug or I'm missing something?

regards.
artb.
-- 
only so many songs can be sung with two lips two lungs and one tongue

--=-j+PUN7zYW5EJwhwmO1g1
Content-Disposition: attachment; filename=login.aspx
Content-Type: text/plain; name=login.aspx; charset=ISO-8859-2
Content-Transfer-Encoding: 8bit

<%@ Page Language="C#" %>
<%@ Import Namespace="System.Xml" %>
<% 
	Response.Charset="UTF-8";
	string sLogin = "";
	string sPasswd = "";
%>

<html>
<head>
    <title>GO-MONO.PL</title>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body>
	<form method='post' action='<% Response.Write(Request.ServerVariables["SCRIPT_NAME"]); %>'>
	<table border=0 align=center>
    <tr>
        <td>Login: </td>
        <td align=right><input type='text' name='login' value='<%
			Response.Write(sLogin);
        %>' size='20' maxlength='30'></td>
    </tr>
    <tr>
        <td>Has┼o: </td>
		<td align=right><input type='password' name='passwd' value='<% 
			Response.Write(sPasswd);
		%>' size='20' maxlength='30'></td>
    </tr>
    <tr>
        <td colspan='2' align='right'><input type='submit' value='LOGUJ'></td>
    </tr>
</table>
	</form>
</body>
</html>

--=-j+PUN7zYW5EJwhwmO1g1--