[Mono-ue] Error Building

Michael Hutchinson m.j.hutchinson at gmail.com
Fri Nov 28 20:01:05 UTC 2014

Yes, the wildcard argument to apply the patches will only work in bash
shell (though bash is included with git for Windows). It's much more
difficult to do with cmd. But applying them one-by-one should work

Code 9009 when running an executable on Windows (usually?) means the
executable file was not found.

It looks like you have a space in the engine path and we're not
quoting it somewhere. Try editing
and change line 10 from:

<MonoUE4AssemblyProcessExe Condition="$(MonoUE4AssemblyProcessExe) ==


<MonoUE4AssemblyProcessExe Condition="$(MonoUE4AssemblyProcessExe) ==

This isn't a perfect fix since it won't work if you explicitly
override the value of MonoUE4AssemblyProcessExe to a value with a
space in it, but it should work for now.

- m

On 28 November 2014 at 05:21, Nima <netnimation at gmail.com> wrote:
> Hey!
> I'm trying to install Mono for Unreal Engine 4, and I have followed all the
> instructions, and they have all worked, except one step. I'm following the
> Installation tab on the website (http://mono-ue.github.io/). Under "Adding
> Mono for Unreal Engine", on Step 3, I tried doing the command "git am
> Engine/Plugins/XamarinUE4/Patches/*", but it said No directory or files
> found, so I figured out that it was the "/*", that didn't work/didn't select
> all files, so I manually entered the command for each file, "git am
> Engine/Plugins/XamarinUE4/Patches/xxx.patch", and it worked for all the
> patches.
> This is the only step on the tutorial that I didn't follow 100%, since it
> didn't work, but the I ran "git am" on all the patches, so I don't think the
> problem is there. Now I'm stuck trying to build the Unreal Editor again in
> Step 4. The first time I built it, earlier in the tutorial it worked
> perfectly, but now it's throwing several errors. Here's a link to the
> errors: http://pastebin.com/HHkWdaP5
> I've tried building it several times, rebooting too, and changing the git
> branch back and forth several times, but it throws the same errors every
> time I try to build it. Also, in Unreal Engine 4, under the File tab, there
> is no Xamarin addon subtab, so I'm guessing it's this build error that is
> messing up the Mono addon in Unreal Engine 4 or is that a seperate problem?
> Hope you can help!
> Thanks,
> - Nima :D
> _______________________________________________
> Mono-ue mailing list
> Mono-ue at lists.ximian.com
> http://lists.ximian.com/mailman/listinfo/mono-ue

Michael Hutchinson ~ https://mhut.ch

More information about the Mono-ue mailing list