[Mono-ue] Unable to generate a Mono Project

Ryan Burnham nitro52 at iinet.net.au
Sun Mar 15 06:58:49 UTC 2015

I tried opening an old preview 4 project I was working on and wasn't able to
build it. I thought I would give creating a new project a go. When I try
creating a Mono with code project it fails and I get this in the output log


Discovering modules, targets and source code for game...

  All packages listed in packages.config are already installed.

  MonoGenerateProjects ->

Binding IntelliSense data...

Writing project files...

Unrecognized Guid format.

UnrealBuildTool Exception: ERROR: MonoGenerateProjects failed with return
code 3. Command:
s\DotNET\MonoGenerateProjects.exe -solutiononly
"E:\SourceControl\UnrealEngine" "C:\Users\Ryan\Documents\Unreal
Projects\monocode" monocode "C:\Users\Ryan\Documents\Unreal

LogGameProjectGeneration: Failed to generate code project files for
"C:\Users\Ryan\Documents\Unreal Projects\monocode\monocode.uproject".



So I tried a Blueprint only one, that works but when I go to add a mono
class and open the project in Xamarin Studio I'm not able to build anything.
First issue I had was about Xamarin.UE4.Framework.props was missing. But it
turned out that it was defaulting to 32bit and I had only built the 64bit
version of the engine source. But the other issue I get is all project
references to the Unreal Engine have disappeared in my old project. And in a
new project they don't include any references either. 


It's not able to find these 2 namespaces


using UnrealEngine.Runtime;
using UnrealEngine.Engine; 


A new project should already have these right? What dll's is it looking for?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.ximian.com/pipermail/mono-ue/attachments/20150315/ef3c4762/attachment.html>

More information about the Mono-ue mailing list