[MonoDevelop] Have resolved some problems with monodevelop not running - but still having problems.

Brett Senior brett_senior at yahoo.com.au
Fri Apr 4 07:01:09 EDT 2008

With respect to earlier e-mails that I sent regarding the fact that I could not run monodevelop (or mdtool) in any form - I have resolved some of the problems which were with my system.  However, when I run monodevelop, mdtool or monodoc - I get the following error message:

FATAL ERROR [2008-04-04 21:25:12Z]: System.DllNotFoundException: libglib-2.0-0.dll
  at (wrapper managed-to-native) GLib.Marshaller:g_malloc (uintptr)
  at GLib.Marshaller.StringToPtrGStrdup (System.String str) [0x00000] 
  at Gtk.Application.SetPrgname () [0x00000] 
  at Gtk.Application.Init () [0x00000] 
  at MonoDevelop.Core.Gui.Dialogs.SetupApp.Run (System.String[] arguments) [0x00000] 
  at MonoDevelop.Core.ApplicationService.StartApplication (System.String appId, System.String[] parameters) [0x00000] 

I found that in the .config files that the libglib-2.0-0.dll is mapped to libglib-2.0.so.0 and I have confirmed that this exists.  On my system it is a symbolic link to the following library - 
lrwxrwxrwx 2 root root 23 2008-04-04 20:22 libglib-2.0.so.0 -> libglib-2.0.so.0.1600.2

I have also checked, via ldconfig -v, that the above is in the cache.  Can someone please help me with this as I have tried all of the things I could think of, and I feel that the above is all that is standing between my system being able to run monodevelop.


Brett Senior

      Get the name you always wanted with the new y7mail email address.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.ximian.com/pipermail/monodevelop-list/attachments/20080404/13957ee3/attachment.html 

More information about the Monodevelop-list mailing list