[MonoTouch] Simulator works, but Device crashes

Geoff Norton gnorton at novell.com
Fri Aug 7 20:21:10 EDT 2009


Ed,

   I have replicated the problem and its being worked on.

-g

On 7-Aug-09, at 7:29 PM, Ed Cianci wrote:

> Hi,
>
> Attached is the project.
>
> When I build Debug|iPhoneSimulator, it runs run. When I build Debug| 
> iPhone and Upload to Device, I can launch the App from my (1G)  
> iPhone, but after entering a zipcode (90210) and clicking the "Go"  
> button, it crashes (app window disappears, creates new crash log  
> entry.)
>
> Thanks, I appreciate your help!
> Ed C.
>
> ________________________________________
> From: Geoff Norton [gnorton at novell.com]
> Sent: Friday, August 07, 2009 6:04 PM
> To: Ed Cianci
> Cc: Abe Gillespie; MonoTouch at lists.ximian.com
> Subject: Re: [MonoTouch] Simulator works, but Device crashes
>
> Please zip up and attach a project which shows the problem and I'll
> take a look.
>
> Sent from my iPhone
>
> On 2009-08-07, at 2:36 PM, Ed Cianci <EdC at interlink1.com> wrote:
>
>> It was worth a try, but no luck!
>> ________________________________________
>> From: Abe Gillespie [abe.gillespie at gmail.com]
>> Sent: Friday, August 07, 2009 5:29 PM
>> To: Ed Cianci
>> Cc: Frank Krueger; MonoTouch at lists.ximian.com
>> Subject: Re: [MonoTouch] Simulator works, but Device crashes
>>
>> Complete random guess, but remove the reference to
>> System.Collections.Generic?
>>
>> -Abe
>>
>> On Fri, Aug 7, 2009 at 4:31 PM, Ed Cianci<EdC at interlink1.com> wrote:
>>> Hi,
>>>
>>> Thanks for the feedback. I've double checked and I'm not currently
>>> using any Generics. There's not much to the app - a textbox, a
>>> button and a label. Attached is my example Main.cs file.
>>>
>>> ________________________________________
>>> From: Frank Krueger [fak at kruegersystems.com]
>>> Sent: Friday, August 07, 2009 4:13 PM
>>> To: Ed Cianci
>>> Cc: MonoTouch at lists.ximian.com
>>> Subject: Re: [MonoTouch] Simulator works, but Device crashes
>>>
>>> I found that my use of generics was causing the same behavior.
>>> After I removed all generics from my code it worked on the device.
>>>
>>> On Fri, Aug 7, 2009 at 4:03 PM, Ed Cianci <EdC at interlink1.com<mailto:EdC at interlink1.com
>>>>> wrote:
>>> Hi,
>>>
>>> I put together a basic app that makes a web request and just
>>> displays the response XML in a label. It runs successfully in the
>>> simulator, but I have deployed it to my iPhone, where it crashes
>>> when responding to a TouchUpInside() event.
>>>
>>> Attached is the crash log retrieved from Xcode.
>>>
>>> (Could this be related to my use of the "-nolink" mtouch arg
>>> workaround mentioned earlier?)
>>>
>>> Thanks!
>>> Ed C.
>>> _______________________________________________
>>> MonoTouch mailing list
>>> MonoTouch at lists.ximian.com<mailto:MonoTouch at lists.ximian.com>
>>> http://lists.ximian.com/mailman/listinfo/monotouch
>>>
>>>
>>>
>>> _______________________________________________
>>> MonoTouch mailing list
>>> MonoTouch at lists.ximian.com
>>> http://lists.ximian.com/mailman/listinfo/monotouch
>>>
>>>
>> _______________________________________________
>> MonoTouch mailing list
>> MonoTouch at lists.ximian.com
>> http://lists.ximian.com/mailman/listinfo/monotouch
> <HelloWeather.zip>



More information about the MonoTouch mailing list