[Gtk-sharp-list] Naming thoughts
19 Jun 2002 18:27:38 -0500
On Wed, 2002-06-19 at 13:17, Rachel Hestilow wrote:
> A fix to the "EmitAdd" problem that doesn't require extensive metadata
> hacking occured to me last night:
> As far as I can tell, nearly all of the signal/method collisions in
> which the method truly only emits a signal are void(void) methods. So
> perhaps the resolution process should look like:
> a) If the method signature is void(void), prepend "Emit" to the method.
> b) Elsewise, append "Emitted" to the signal.
I don't like having Emitted on the end of signal names any better than
having Emit on the front of Method names, though it would suck less than
the current solution in some cases (eg the EmitAdd wart).
What I had intended to do was to add a "Collision" class to manually map
the collisions. I think an Add method with an Added signal is nicer than
AddEmitted, for example. This should be a fairly static list of
collisions, so it's not like it will take a ton of maintenance going
forward, and if we put a generation warning when an unresolved collision
is detected, we'll be better prepared to lobby for Gtk+ fixes in new API
additions as they occur.
I don't think this falls into the category of extensive metadata