[Gtk-sharp-list] Naming conventions: a suggestion.
20 Jun 2002 23:18:57 -0500
On Thu, 2002-06-20 at 20:19, Miguel de Icaza wrote:
> Hey guys,
> A suggestion: would it be possible to rename things like `EmitAdd' to
> be `Add' and rename the events which are now called like `Add' to
There is already a bug logged on this, and I've discussed it with
several folks on irc as well. My goal is to have methods be present
tense and signals be past tense whenever collisions occur. For example,
the EmitAdd wart that every whines about immediately upon seeing the
example code would resolve to an Add method and an Added signal. The
EmitAdd solution was simple and mechanical and at least got things
I am trying to decide whether to resolve these collisions when
generating XML, or in the code generator. I'm inclined to do it in the
XML production, because then any other OO languages that choose to reuse
the XML will not need to work around it in their code generators.