[Gtk-sharp-list] GladeWidget attribute renaming.
Charles Iliya Krempeaux
13 Mar 2003 15:29:47 -0800
On Thu, 2003-03-13 at 09:33, Miguel de Icaza wrote:
> I would like to rename `GladeWidgetAttribute' to `WidgetAttribute',
> because it is already part of the Glade namespace. Ie, currently
> without using statements you end up with:
> Gtk.Widget blah;
> We could do this by having first a `WidgetAttribute', and allowing
> the use of `GladeWidget' and `Widget' for now, but moving towards
> deprecating GladeWidget in the future.
I'm for it.
I personally prefer using full namespace names. I.e., I prefer using
As opposed to:
(I like being able to tell where things are coming from and
what things belong to at a glace.)
Charles Iliya Krempeaux, BSc
Reptile Consulting & Services 604-REPTILE http://www.reptile.ca/