[Gtk-sharp-list] GladeWidget attribute renaming.
13 Mar 2003 20:52:32 -0600
> On Thu, 2003-03-13 at 09:33, Miguel de Icaza wrote:
> > Hello,
> > I would like to rename `GladeWidgetAttribute' to `WidgetAttribute',
> > because it is already part of the Glade namespace. Ie, currently
> > without using statements you end up with:
> > [Glade.GladeWidget]
> > Gtk.Widget blah;
> > We could do this by having first a `WidgetAttribute', and allowing
> > the use of `GladeWidget' and `Widget' for now, but moving towards
> > deprecating GladeWidget in the future.
> > Comments?
Sounds right. Although I'd just make the jump now, instead of
deprecating. We're nowhere near stable yet, and anyone using the
binding has to be ready to adapt to this kind of stuff. We break api
with almost every commit.
Mike Kestner <firstname.lastname@example.org>