[Gtk-sharp-list] Problems with GTk# on win2k

Daniel Morgan danielmorgan@verizon.net
Sun, 15 Feb 2004 18:19:05 -0500

This windows installer has both mono 0.30 and gtk# 0.15.  Be aware that the
link word-wrapped.


If that link does not work for you, look here
for Mono 0.30 only or a Mono 0.30/gtk# 0.15 installer

A gtk# 0.15 only installer can be found here

BTW, as i have stated before, mono, gtk#, gtk+ 2.2.4, and dependencies must
be in the same prefix.  The installer above does this.

-----Original Message-----
From: Lawrence Oluyede [mailto:l.oluyede@virgilio.it]
Sent: Sunday, February 15, 2004 5:33 PM
To: Daniel Morgan
Subject: Re: [Gtk-sharp-list] Problems with GTk# on win2k

Daniel Morgan wrote:
> put your binaries (mono_prefix\bin) and class libraries (mono_prefix\lib)
> your PATH
> set MONG_CFG_PATH to your mono_prefix\etc
> set MONO_PATH to where your mono_prefix\lib
> if running on mono: mono, gtk+, and gtk# and their dependencies must be in
> the same prefix.
> if you installed mono from an installer, take a look at monobasepath.bat
> found in your Windows directory.

No way, i can't get work gtk# neither in mono nor in MS .NET :(

Here is the situation:

Gtk+ installed in E:\Programmi\File comuni\GTK\2.0 (via the
win32 installer)
GTK# 0.15 installed in E:\Programmi\File comuni\GtkSharp
.NET 1.1 installed in the std dirs with VS.NET (i use mainly VS.NET for
my stuff)
Mono 0.30 in E:\Programmi\Mono-0.30

the environment vars are (i tried quite everything):

LIB=(stuff of VS.NET);E:\Programmi\File
comuni\GTK\2.0\lib;E:\Programmi\File comuni\GtkSharp\lib
PATH=(various stuff);E:\Programmi\Mono-0.30\bin;E:\Programmi\File

The problems are:
Mono doesn't find the dlls in the path, but if i copy the needed dlls
the hello world example compiles. The same for VS.NET, referencing the
dlls (vs.net copies the needed dlls in bin\Debug) gets a successful
compile step. Executing the .exe with mono results in a message box
stating "could not find the entry point libiconv_set_relocation_prefix
of the procedure in the dynamic link library iconv.dll" and after some
button presses i get a System.DllNotFoundException cause it doesn't find
  libgtk-win32-2.0.0.dll (the file exists but it doesn't find it; i
tried to copy in the same dir of the example but it doesn't work). The
same using MS.NET

Hope this helps someone to understand the problem