[Gtk-sharp-list] List Store API suggestion
Sat, 21 Feb 2004 16:06:41 +1100
I have a suggested change to the ListStore API wraping in gtk#.
I read in a gtk+ doc somewhere that calling IterNChildren(null) will
return the row count of the ListStore, where as calling
IterNChildren(iter) will return the child count of the specified iter.
I also noticed in monodoc that there seems to be an override of
IterNChildren(TreeIter iter) to which is simply IterNChildren(). This
override seems to be there specifically to get the ListStore's row
This naming seems a little ambiguous. I was thinking we should change in
the following way:
- Change IterNChildren() be something like GetRowCount()
- Have IterNChildren(TreeIter iter) call GetRowCount if iter == null
This approach satisfies users coming from a gtk+ (those calling
IterNChildren with null) angle and those coming from a .Net angle (those
Any problems with that ?