[Gtk-sharp-list] libglade-WARNING **: could not find internal child `entry' in parent of type `GtkCombo'

Anset anset@anset.org
Mon, 6 Sep 2004 12:04:11 +0200


I'm developing on a gentoo linux box using mono, gtk-sharp and glade-2
(using libglade).
On that linux machine I have no problems.

However, when I copy the resulting "exe" from the gentoo box to my win xp
pc, I run into this error when the exe is started:

(<unknown>:1592): libglade-WARNING **: Could not load support for `gnome':
The specified module could not be found.
(<unknown>:1592): libglade-WARNING **: could not find internal child `entry'
in parent of type `GtkCombo'
(<unknown>:1592): libglade-WARNING **: unknown property `selection_mode' for
class `GtkWindow'
(<unknown>:1592): Gtk-WARNING **: Attempting to add a widget with type
GtkListItem to a GtkWindow, but as a GtkBin subclass a GtkWindow can only
contain one widget at a time; it already contains a widget of type

The first one and the third one seem not much of a problem, and I think that
the last one is a result of the second one. So that is the one I am trying
to solve.

I found that some months ago, the people from pygtk apparantly solved this
bug: http://www.daa.com.au/pipermail/pygtk/2004-April/007459.html, but now I
am getting it.

I am using the Gtk# Win32 Installer for Microsoft .NET Framework 1.1 SDK
from novell forge.

I looked at the gtk# bugzilla but could not find an open bug about this, but
I admit my "bugzilla search skills" are few.

Does anybody else have this problem, and if so, is there a workaround?

Best regards,